$re = '/Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*),Microsoft-Windows-Eventlog,(?P<event_id>\d+),(?P<category>.*),(?P<event_message>.*)\s+(?P<amount_of_events>\d+)/';
$str = 'Audit Success,06/07/2017 15:16:10,Microsoft-Windows-Eventlog,1101,Event processing,Audit events have been dropped by the transport. 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);