import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*),Microsoft-Windows-Eventlog,(?P<event_id>\\d+),(?P<category>.*),(?P<event_message>.*)\\s+(?P<amount_of_events>\\d+)";
final String string = "Audit Success,06/07/2017 15:16:10,Microsoft-Windows-Eventlog,1101,Event processing,Audit events have been dropped by the transport. 0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}