re = /^data:([A-Za-z-+\/]+);base64,(.+)$/m
str = 'data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAABDgAAAeACAYAAAArYecKAAAABmJLR0QA/wD/AP+gvaeTAAAgAElEQVR4nKy9W4LkOK4saIAi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end