package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^data:([A-Za-z-+\/]+);base64,(.+)$`)
var str = `data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAABDgAAAeACAYAAAArYecKAAAABmJLR0QA/wD/AP+gvaeTAAAgAElEQVR4nKy9W4LkOK4saIAi`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}