$re = '/^([a-zA-z0-9]+)[ \t]+([^ \t]+)[ \t]+([^ \t]+)$/';
$str = 'int2char GF@lel bool@true';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);