using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-z0-9]+)[ \t]+([^ \t]+)[ \t]+([^ \t]+)$";
string input = @"int2char GF@lel bool@true";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}