re = /([0-9]{1,})\s([0-9]{4}-[0-9]{2}-[0-9]{2})\s([0-9]{1,2}:[0-9]{1,2})\s(0|1)\s(0|1)/m
str = '123 2017-08-01 20:15 1 0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end