const regex = new RegExp('([0-9]{1,})\\s([0-9]{4}-[0-9]{2}-[0-9]{2})\\s([0-9]{1,2}:[0-9]{1,2})\\s(0|1)\\s(0|1)', 'gm')
const str = `123 2017-08-01 20:15 1 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}