re = /^([0-9]{2})((?:\.([0-9]{1,2}))?$|((?:\.([0-9]{2}))?\.([0-9]{1,2})))?$/m
str = '12.10.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end