$re = '/^([0-9]{2})((?:\.([0-9]{1,2}))?$|((?:\.([0-9]{2}))?\.([0-9]{1,2})))?$/m';
$str = '12.10.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);