re = /^ *((?:(?:[^\<\>]+)(?:(?:[^\<\> ]+) *)?(?:[^\<\>]+))) *\<?([^\<\> ]+)\>$/m
str = ' First Middle Last <test@test.com>
Test name <test@test.com>
<test@test.com>
test@test.com
test@test.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end