$re = '/^ *((?:(?:[^\<\>]+)(?:(?:[^\<\> ]+) *)?(?:[^\<\>]+))) *\<?([^\<\> ]+)\>$/m';
$str = ' First Middle Last <test@test.com>
Test name <test@test.com>
<test@test.com>
test@test.com
test@test.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);