$re = '/^(?:([a-zA-Z][\w-]*)\.)(?:([\w-]*)\.)(?:([\w-]*)\.)(?:([\w-]*))$/m';
$str = 'tese-0001.test.com.cn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);