package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:([a-zA-Z][\w-]*)\.)(?:([\w-]*)\.)(?:([\w-]*)\.)(?:([\w-]*))$`)
var str = `tese-0001.test.com.cn`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}