import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(000[1-9]|00[1-9]\\d|0[1-9]\\d\\d|100\\d|10[1-9]\\d|1[1-9]\\d{2}|[2-9]\\d{3}|[1-9]\\d{4}|1\\d{5}|2[0-6]\\d{4}|27[0-4]\\d{3}|275[0-6]\\d{2}|2757[0-5]\\d|275760)-W(([1-4]\\d)|(5[0-3])|0[1-9])$";
final String string = "min possible year :\n"
+ "0001-W10\n\n"
+ "max possible year :\n"
+ "275760-W05\n\n"
+ "min possible week :\n"
+ "1969-W01\n\n"
+ "max possible week :\n"
+ "1969-W53\n\n";
final String subst = "$1-W$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}