# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(000[1-9]|00[1-9]\d|0[1-9]\d\d|100\d|10[1-9]\d|1[1-9]\d{2}|[2-9]\d{3}|[1-9]\d{4}|1\d{5}|2[0-6]\d{4}|27[0-4]\d{3}|275[0-6]\d{2}|2757[0-5]\d|275760)-W(([1-4]\d)|(5[0-3])|0[1-9])$/$1-W$2/gm;t' <<< "min possible year :
0001-W10
max possible year :
275760-W05
min possible week :
1969-W01
max possible week :
1969-W53
"