const regex = /^((0[1-9]|1[0-2])|([1-9]{1}))\/([0-9]{4}|[0-9]{2})$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((0[1-9]|1[0-2])|([1-9]{1}))\\\/([0-9]{4}|[0-9]{2})$', 'mg')
const str = `02/13
0213
022013
02/2013
02/20
02/2
02/2032`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}