import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((0[1-9]|1[0-2])|([1-9]{1}))\\/([0-9]{4}|[0-9]{2})$";
final String string = "02/13\n"
+ "0213\n"
+ "022013\n"
+ "02/2013\n"
+ "02/20\n"
+ "02/2\n"
+ "02/2032";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}