# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
[[:blank:]]*+(?:[\[\(].*[\]\)][[:blank:]]*+)?(.*?)[[:blank:]\[\(]*+([1-2]\d{3}).*
"""
test_str = ("2 Fast 2 Furious [2003] [SD]\n"
"2 Fast 2 Furious (2003) [SD]\n"
"2 Fast 2 Furious ((2003) [SD]\n"
"A Goofy Movie (1995) (HD) (720p)\n"
"[test]A Goofy Movie (1995) (HD) (720p)\n"
"(test) A Goofy Movie (1995) (HD) (720p)\n"
"2 Fast 2 Furious 2003 \n"
" 2 Fast 2 Furious 2003\n"
"The Lion King 2- Simba's Pride (1998) (HD) (1080p)\n"
"The.Grand.Budapest.Hotel.2014.1080p.BluRay.x264-BLOW\n"
"Another.Earth.2011.LIMITED.720p.BluRay.X264-AMIABLE\n"
"The.Green.Mile.1999.720p.BluRay.x264-HDCLASSiCS\n"
"The Road 2009 Bluray DTS 720 p - TRiNiTY\n"
"Dead Poets Society (1989) 720p Blu-ray x264 DTS MSubs [DDR]\n"
"Garden.State.2004.720p.BluRay.X264-AMIABLE\n")
subst = "\\1 (\\2) \\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.