import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[[:blank:]]*+(?:[\\[\\(].*[\\]\\)][[:blank:]]*+)?(.*?)[[:blank:]\\[\\(]*+([1-2]\\d{3}).*\n";
final String string = "2 Fast 2 Furious [2003] [SD]\n"
+ "2 Fast 2 Furious (2003) [SD]\n"
+ "2 Fast 2 Furious ((2003) [SD]\n"
+ "A Goofy Movie (1995) (HD) (720p)\n"
+ "[test]A Goofy Movie (1995) (HD) (720p)\n"
+ "(test) A Goofy Movie (1995) (HD) (720p)\n"
+ "2 Fast 2 Furious 2003 \n"
+ " 2 Fast 2 Furious 2003\n"
+ "The Lion King 2- Simba's Pride (1998) (HD) (1080p)\n"
+ "The.Grand.Budapest.Hotel.2014.1080p.BluRay.x264-BLOW\n"
+ "Another.Earth.2011.LIMITED.720p.BluRay.X264-AMIABLE\n"
+ "The.Green.Mile.1999.720p.BluRay.x264-HDCLASSiCS\n"
+ "The Road 2009 Bluray DTS 720 p - TRiNiTY\n"
+ "Dead Poets Society (1989) 720p Blu-ray x264 DTS MSubs [DDR]\n"
+ "Garden.State.2004.720p.BluRay.X264-AMIABLE\n";
final String subst = "\\1 (\\2) \\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}