const regex = /box(?!-shadow) /g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('box(?!-shadow) ', 'g')
const str = `positive lookahead
box(?=-shadow)
https://youtu.be/aIEjh0YsxWA?t=309
// select box only if what comes after it IS -shadow
box-sizing
shape-shadow
------------------------------------------------------------------
negative lookahead
box(?!-shadow)
// select box only if what comes after it IS NOT shadow
box-sizing
shape-shadow
------------------------------------------------------------------
negative look behind
(?<!jeffery).+
https://youtu.be/aIEjh0YsxWA?t=212
// this string cannot come before the @
jeffrey@envato.com
joe@envato.com
------------------------------------------------------------------
positive look behind
(?<=box-)sizing
https://youtu.be/aIEjh0YsxWA?t=337
// only want to select 'sizing' if what comes before it is 'box'
// select sizing as long as what comes before it is 'box'
box-sizing
shape-sizing
------------------------------------------------------------------
negative look behind
(?<!box-)sizing
// anything can come before it except 'box'
box-sizing
shape-sizing
-----------------------------------------------------------------
positive lookahead
@.+(?=\\.[a-z]{2,4})
// Matches a group after your main expression without including it in the result
wilson@gmail.com
frank@france.fr
joe@paris.france
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}