package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<g1>^.+)(?<g2>\|)(?<g3>\w*)`)
var str = `VERNIZ FOSCO PU 5:1|6190734832
VERNIZ FOSCO PU BICO|6190737676
VERNIZ FOSCO SAYERLACK 900ML|5482326670
VERNIZ MARITIMO INCOLOR - [3,6 LT]|6605544243
VERNIZ MARITIMO INCOLOR - [900 ML]|6605544245
VERNIZ PU 0491 - DUXONE|2739465076
VERNIZ PU 10.000 SKYLACK|5026534877
VERNIZ PU 6100 - LAZZURIL|2422595915
VERNIZ PU 8050 - LAZZURIL|2422595909
VERNIZ PU BRILHO 20|5109244189
VERNIZ PU FOSCO - LAZZURIL|2730718333
VERNIZ PU FOSCO - [750 ML] - SKYLACK|3551612362
VERNIZ PU MASCARA NEGRA|4988056487
VERNIZ PU SEMI-FOSCO|4717802264
VERNIZ PU SEMI-FOSCO - 3600 ML - FARBEN|3850897363
VERNIZ PU SEMI-FOSCO - 750 ML|4909315994
VERNIZ PU SEMI-FOSCO - 900 ML - FARBEN|3850897360
VERNIZ PU SEMI-FOSCO 750ML|5026534871
VERNIZ PU TRANSPARENTE FOSCO – 6713 - SAYERLACK|3475203973
VERNIZ SKYFAST HS 5:1 - SKYDUR - [900 ML]|4359364616
VERNIZ ULTRA 7000|2587796536
VESUVIO|4507424840
VIOLETA PU C/ CAT|6902409301
WASH PRIMER - [600 M|6190739255
WASH PRIMER - [600 ML] - BRAZILIAN|6121038554
WASH PRIMER VINILICO|6190737471
WASH/PRETO FOSCO - DX9000 - [600 ML] - BRASILUX - KIT|2422594658
WASH/PRETO FOSCO - DX9000 - [600 ML] - DUXONE - KIT|3147792988
WASH/PRETO FOSCO - [600 ML] - MAXIRUBBER|4528448069
WASH/PRETO FOSCO - [900 ML] - MAZA - KIT|3583355677
WASHPRIMER 1/4|6190735139
WHITE LUB - [300 ML]|4648227158
ZARCAO - [3,6 LT]|6605544226
`
var substitution = "${g3}"
fmt.Println(re.ReplaceAllString(str, substitution))
}