#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<g1>^.+)(?<g2>\|)(?<g3>\w*)"
Local $sString = "VERNIZ FOSCO PU 5:1|6190734832" & @CRLF & _
"VERNIZ FOSCO PU BICO|6190737676" & @CRLF & _
"VERNIZ FOSCO SAYERLACK 900ML|5482326670" & @CRLF & _
"VERNIZ MARITIMO INCOLOR - [3,6 LT]|6605544243" & @CRLF & _
"VERNIZ MARITIMO INCOLOR - [900 ML]|6605544245" & @CRLF & _
"VERNIZ PU 0491 - DUXONE|2739465076" & @CRLF & _
"VERNIZ PU 10.000 SKYLACK|5026534877" & @CRLF & _
"VERNIZ PU 6100 - LAZZURIL|2422595915" & @CRLF & _
"VERNIZ PU 8050 - LAZZURIL|2422595909" & @CRLF & _
"VERNIZ PU BRILHO 20|5109244189" & @CRLF & _
"VERNIZ PU FOSCO - LAZZURIL|2730718333" & @CRLF & _
"VERNIZ PU FOSCO - [750 ML] - SKYLACK|3551612362" & @CRLF & _
"VERNIZ PU MASCARA NEGRA|4988056487" & @CRLF & _
"VERNIZ PU SEMI-FOSCO|4717802264" & @CRLF & _
"VERNIZ PU SEMI-FOSCO - 3600 ML - FARBEN|3850897363" & @CRLF & _
"VERNIZ PU SEMI-FOSCO - 750 ML|4909315994" & @CRLF & _
"VERNIZ PU SEMI-FOSCO - 900 ML - FARBEN|3850897360" & @CRLF & _
"VERNIZ PU SEMI-FOSCO 750ML|5026534871" & @CRLF & _
"VERNIZ PU TRANSPARENTE FOSCO – 6713 - SAYERLACK|3475203973" & @CRLF & _
"VERNIZ SKYFAST HS 5:1 - SKYDUR - [900 ML]|4359364616" & @CRLF & _
"VERNIZ ULTRA 7000|2587796536" & @CRLF & _
"VESUVIO|4507424840" & @CRLF & _
"VIOLETA PU C/ CAT|6902409301" & @CRLF & _
"WASH PRIMER - [600 M|6190739255" & @CRLF & _
"WASH PRIMER - [600 ML] - BRAZILIAN|6121038554" & @CRLF & _
"WASH PRIMER VINILICO|6190737471" & @CRLF & _
"WASH/PRETO FOSCO - DX9000 - [600 ML] - BRASILUX - KIT|2422594658" & @CRLF & _
"WASH/PRETO FOSCO - DX9000 - [600 ML] - DUXONE - KIT|3147792988" & @CRLF & _
"WASH/PRETO FOSCO - [600 ML] - MAXIRUBBER|4528448069" & @CRLF & _
"WASH/PRETO FOSCO - [900 ML] - MAZA - KIT|3583355677" & @CRLF & _
"WASHPRIMER 1/4|6190735139" & @CRLF & _
"WHITE LUB - [300 ML]|4648227158" & @CRLF & _
"ZARCAO - [3,6 LT]|6605544226" & @CRLF & _
""
Local $sSubst = "${g3}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)