// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"/guestAccounts/.{2,100}/somethingElse").unwrap();
let string = "/guestAccounts/c4c3b592-94ec-41dd-9cea-257875705799/somethingElse";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}