$re = '`/guestAccounts/.{2,100}/somethingElse`';
$str = '/guestAccounts/c4c3b592-94ec-41dd-9cea-257875705799/somethingElse';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);