# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:
^
\s*
(?<host>[\w-\.]*)
\s*
(?<rectype>\w*)
\s*
(?<value>[\w\.-].*)
\s*$
)
"""
test_str = ("> ls -d midlandls.pncint.net \n"
"[pasum60ad02.pncint.net]\n"
" midlandls.pncint.net. SOA vasan60ad03.pncint.net ip.address.request.pncbank.com. (562550790 10800 3600 1209600 60)\n"
" midlandls.pncint.net. NS vaash60ad04.pncint.net \n"
" midlandls.pncint.net. NS pasum60ad11.pncint.net \n"
" midlandls.pncint.net. NS pasum60ad01.pncint.net \n"
" midlandls.pncint.net. NS pasum60ad02.pncint.net \n"
" arcs-msmq CNAME weka357w.prod.pncint.net\n"
" bar-rpt CNAME wbar303a.prod.pncint.net\n"
" Bin CNAME services-gf2.midlandls.pncint.net\n"
" cigna-msmq CNAME welm350w.prod.pncint.net\n"
" citigroup-msmq CNAME welm352w.prod.pncint.net\n"
" Cwm CNAME services-gf2.midlandls.pncint.net\n"
" Cwm-app CNAME services-gf2.midlandls.pncint.net\n"
" cwm-rpt CNAME wcwm316a.prod.pncint.net\n"
" dbank-msmq CNAME welm344w.prod.pncint.net\n"
" egs CNAME egs-gf0.midlandls.pncint.net\n"
" egs-gf0 A 10.15.5.238\n"
" egs-gf1 A 10.38.5.238\n"
" egs-snat-gf0 A 10.15.7.238\n"
" egs-snat-gf1 A 10.38.7.238\n"
" eka CNAME services-gf2.midlandls.pncint.net\n"
" elm CNAME services-gf2.midlandls.pncint.net\n"
" fdic-msmq CNAME welm358w.prod.pncint.net\n"
" genworth-msmq CNAME welm365w.prod.pncint.net\n"
" icsg-msmq CNAME welm375w.prod.pncint.net\n"
" iru CNAME services-gf2.midlandls.pncint.net\n"
" iru-rpt CNAME wiru307a.prod.pncint.net\n"
" mat CNAME services-gf2.midlandls.pncint.net\n"
" mat-app CNAME services-gf2.midlandls.pncint.net\n"
" mat-rpt CNAME wmat302a.prod.pncint.net\n"
" mde CNAME services-gf2.midlandls.pncint.net\n"
" mde-internet CNAME services-gf2.midlandls.pncint.net\n"
" mfn CNAME services-gf2.midlandls.pncint.net\n"
" mfn-app CNAME services-gf2.midlandls.pncint.net\n"
" mfn-rpt CNAME wmfn318a.prod.pncint.net\n"
" mis CNAME services-gf2.midlandls.pncint.net\n"
" mis-app CNAME services-gf2.midlandls.pncint.net\n"
" mis-rpt CNAME wmis308a.prod.pncint.net\n"
" mls-msmq CNAME weka353w.prod.pncint.net\n"
" mvm CNAME services-gf1.midlandls.pncint.net\n"
" mvm-rpt CNAME wmvm302a.prod.pncint.net\n"
" pii CNAME services-gf2.midlandls.pncint.net\n"
" pnc-msmq CNAME weka373w.prod.pncint.net\n"
" pnclms-msmq CNAME weka349w.prod.pncint.net\n"
" rdt CNAME services-gf1.midlandls.pncint.net\n"
" services-gf1 A 10.26.64.229\n"
" services-gf2 A 10.28.8.229\n"
" services-snat-gf1 A 10.26.68.249\n"
" services-snat-gf2 A 10.28.12.227\n"
" wdunlop-msmq CNAME welm31bw.prod.pncint.net\n"
" wlm CNAME services-gf2.midlandls.pncint.net\n"
" wlm-app CNAME wwlm305w.prod.pncint.net\n"
" wlm-rpt CNAME wwlm306a.prod.pncint.net\n"
" midlandls.pncint.net. SOA vasan60ad03.pncint.net ip.address.request.pncbank.com. (562550790 10800 3600 1209600 60)\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.