#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?:" & @CRLF & _
" ^" & @CRLF & _
" \s*" & @CRLF & _
" (?<host>[\w-\.]*)" & @CRLF & _
" \s*" & @CRLF & _
" (?<rectype>\w*)" & @CRLF & _
" \s*" & @CRLF & _
" (?<value>[\w\.-].*)" & @CRLF & _
" \s*$" & @CRLF & _
")"
Local $sString = "> ls -d midlandls.pncint.net " & @CRLF & _
"[pasum60ad02.pncint.net]" & @CRLF & _
" midlandls.pncint.net. SOA vasan60ad03.pncint.net ip.address.request.pncbank.com. (562550790 10800 3600 1209600 60)" & @CRLF & _
" midlandls.pncint.net. NS vaash60ad04.pncint.net " & @CRLF & _
" midlandls.pncint.net. NS pasum60ad11.pncint.net " & @CRLF & _
" midlandls.pncint.net. NS pasum60ad01.pncint.net " & @CRLF & _
" midlandls.pncint.net. NS pasum60ad02.pncint.net " & @CRLF & _
" arcs-msmq CNAME weka357w.prod.pncint.net" & @CRLF & _
" bar-rpt CNAME wbar303a.prod.pncint.net" & @CRLF & _
" Bin CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" cigna-msmq CNAME welm350w.prod.pncint.net" & @CRLF & _
" citigroup-msmq CNAME welm352w.prod.pncint.net" & @CRLF & _
" Cwm CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" Cwm-app CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" cwm-rpt CNAME wcwm316a.prod.pncint.net" & @CRLF & _
" dbank-msmq CNAME welm344w.prod.pncint.net" & @CRLF & _
" egs CNAME egs-gf0.midlandls.pncint.net" & @CRLF & _
" egs-gf0 A 10.15.5.238" & @CRLF & _
" egs-gf1 A 10.38.5.238" & @CRLF & _
" egs-snat-gf0 A 10.15.7.238" & @CRLF & _
" egs-snat-gf1 A 10.38.7.238" & @CRLF & _
" eka CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" elm CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" fdic-msmq CNAME welm358w.prod.pncint.net" & @CRLF & _
" genworth-msmq CNAME welm365w.prod.pncint.net" & @CRLF & _
" icsg-msmq CNAME welm375w.prod.pncint.net" & @CRLF & _
" iru CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" iru-rpt CNAME wiru307a.prod.pncint.net" & @CRLF & _
" mat CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" mat-app CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" mat-rpt CNAME wmat302a.prod.pncint.net" & @CRLF & _
" mde CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" mde-internet CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" mfn CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" mfn-app CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" mfn-rpt CNAME wmfn318a.prod.pncint.net" & @CRLF & _
" mis CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" mis-app CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" mis-rpt CNAME wmis308a.prod.pncint.net" & @CRLF & _
" mls-msmq CNAME weka353w.prod.pncint.net" & @CRLF & _
" mvm CNAME services-gf1.midlandls.pncint.net" & @CRLF & _
" mvm-rpt CNAME wmvm302a.prod.pncint.net" & @CRLF & _
" pii CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" pnc-msmq CNAME weka373w.prod.pncint.net" & @CRLF & _
" pnclms-msmq CNAME weka349w.prod.pncint.net" & @CRLF & _
" rdt CNAME services-gf1.midlandls.pncint.net" & @CRLF & _
" services-gf1 A 10.26.64.229" & @CRLF & _
" services-gf2 A 10.28.8.229" & @CRLF & _
" services-snat-gf1 A 10.26.68.249" & @CRLF & _
" services-snat-gf2 A 10.28.12.227" & @CRLF & _
" wdunlop-msmq CNAME welm31bw.prod.pncint.net" & @CRLF & _
" wlm CNAME services-gf2.midlandls.pncint.net" & @CRLF & _
" wlm-app CNAME wwlm305w.prod.pncint.net" & @CRLF & _
" wlm-rpt CNAME wwlm306a.prod.pncint.net" & @CRLF & _
" midlandls.pncint.net. SOA vasan60ad03.pncint.net ip.address.request.pncbank.com. (562550790 10800 3600 1209600 60)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")