$re = '/\\\\$\n^\s+/m';
$str = 'add add-default-route=yes comment="WAN ROSTELECOM" disabled=no interface=\\
ether1 keepalive-timeout=disabled name=pppoe-wan1-rostel password=\\
313131231 use-peer-dns=yes user=21412431241';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);