const regex = /\\$\n^\s+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\$\\n^\\s+', 'gm')
const str = `add add-default-route=yes comment="WAN ROSTELECOM" disabled=no interface=\\
ether1 keepalive-timeout=disabled name=pppoe-wan1-rostel password=\\
313131231 use-peer-dns=yes user=21412431241`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}