re = /\b(?:[ptkmnlswj]?
(?:(?<=w)[aei]|
(?<=[jt])[aeou]|
(?<=[pkmnls])[aeiou]|
(?<=\b)[aeiou])
(?:n(?![nm]?[aeiou]))?)+\b/ix
str = 'panna
jijin
titin
wowu
wonwun
tewun
tetin
tejin
teji
aan
---
mama
seme
pona
toki pona li toki suwi
jan Lili li lili
ni li ilo Lekula Epesen. ni li ken lanpan e nimi mute
eni
nanma
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end