import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:[ptkmnlswj]?\n"
+ "(?:(?<=w)[aei]|\n"
+ "(?<=[jt])[aeou]|\n"
+ "(?<=[pkmnls])[aeiou]|\n"
+ "(?<=\\b)[aeiou])\n"
+ "(?:n(?![nm]?[aeiou]))?)+\\b";
final String string = "panna\n"
+ "jijin\n"
+ "titin\n"
+ "wowu\n"
+ "wonwun\n"
+ "tewun\n"
+ "tetin\n"
+ "tejin\n"
+ "teji\n"
+ "aan\n"
+ "---\n"
+ "mama\n"
+ "seme\n"
+ "pona\n"
+ "toki pona li toki suwi\n"
+ "jan Lili li lili\n\n"
+ "ni li ilo Lekula Epesen. ni li ken lanpan e nimi mute \n"
+ "eni\n\n"
+ "nanma\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}