use strict;
my $str = 'http://bouquet-delivery.ru/index.php
http://bouquet-delivery.ru/home
http://bouquet-delivery.ru/home/
http://www.bouquet-delivery.ru/
http://www.bouquet-delivery.ru/index.php
http://www.bouquet-delivery.ru/index.html
http://www.bouquet-delivery.ru/index.htm
http://www.bouquet-delivery.ru/index/
http://www.bouquet-delivery.ru/home
http://www.bouquet-delivery.ru/home/
http://www.bouquet-delivery.ru/home.php
http://www.bouquet-delivery.ru/home.html
http://www.bouquet-delivery.ru/home.htm
http://www.bouquet-delivery.ru/main
http://www.bouquet-delivery.ru/main/
http://www.bouquet-delivery.ru/main.php
http://www.bouquet-delivery.ru/main.html
http://www.bouquet-delivery.ru/main.htm';
my $regex = qr/(?:index|home|main)(?:[\.\/](?:php|html?|\/?))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}