import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:index|home|main)(?:[\\.\\/](?:php|html?|\\/?))?$";
final String string = "http://bouquet-delivery.ru/index.php\n"
+ "http://bouquet-delivery.ru/home\n"
+ "http://bouquet-delivery.ru/home/\n"
+ "http://www.bouquet-delivery.ru/\n"
+ "http://www.bouquet-delivery.ru/index.php\n"
+ "http://www.bouquet-delivery.ru/index.html\n"
+ "http://www.bouquet-delivery.ru/index.htm\n"
+ "http://www.bouquet-delivery.ru/index/\n"
+ "http://www.bouquet-delivery.ru/home\n"
+ "http://www.bouquet-delivery.ru/home/\n"
+ "http://www.bouquet-delivery.ru/home.php\n"
+ "http://www.bouquet-delivery.ru/home.html\n"
+ "http://www.bouquet-delivery.ru/home.htm\n"
+ "http://www.bouquet-delivery.ru/main\n"
+ "http://www.bouquet-delivery.ru/main/\n"
+ "http://www.bouquet-delivery.ru/main.php\n"
+ "http://www.bouquet-delivery.ru/main.html\n"
+ "http://www.bouquet-delivery.ru/main.htm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}