$re = '/^(__version__)(\s?=\s?)+("(.*)")/';
$str = '__version__ = "0.1.1.1"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);