const regex = /(^[ \t]*)Function([^\n\;\/]*);?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[ \\t]*)Function([^\\n\\;\\\/]*);?', 'gm')
const str = `// Возвращает значения Х и У
Function UseResolutionMultipler(x# Var,y# Var) ;
//SetScale ScX,ScY
End Function ;
Function DrawBar(x,y,Width ,Height,CurPts,MaxPts);
jjj
End Function;`;
const subst = `$1 public static$2\n$1\{`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);