package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[ \t]*)Function([^\n\;\/]*);?`)
var str = `// Возвращает значения Х и У
Function UseResolutionMultipler(x# Var,y# Var) ;
//SetScale ScX,ScY
End Function ;
Function DrawBar(x,y,Width ,Height,CurPts,MaxPts);
jjj
End Function;`
var substitution = "$1 public static$2\n$1\{"
fmt.Println(re.ReplaceAllString(str, substitution))
}