$re = '/\(\d+,\s\d+\)/m';
$str = '[WHCSWD] [decimal](3, 1) NULL,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);