package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(\d+,\s\d+\)`)
var str = `[WHCSWD] [decimal](3, 1) NULL,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}