# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^,\n]+"
test_str = ("4/5/2015 13:34,Apples,73\n"
"4/5/2015 3:41,Cherries,85\n"
"4/6/2015 12:46,Pears,14\n"
"4/8/2015 8:59,Oranges,52\n"
"4/10/2015 2:07,Apples,152\n"
"4/10/2015 18:10,Bananas,23\n"
"4/10/2015 2:40,Strawberries,98")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.