import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^,\\n]+";
final String string = "4/5/2015 13:34,Apples,73\n"
+ "4/5/2015 3:41,Cherries,85\n"
+ "4/6/2015 12:46,Pears,14\n"
+ "4/8/2015 8:59,Oranges,52\n"
+ "4/10/2015 2:07,Apples,152\n"
+ "4/10/2015 18:10,Bananas,23\n"
+ "4/10/2015 2:40,Strawberries,98";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}