import Foundation
let pattern = #"(?<!\S).(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a interior Casquillo Dint.50 100
brg aligning Self MM161Z end rod
del eje4 Junta hendidura
352 Junta tórica .20279
2z/C3GJN Rodamiento
pos. Ser. 440PM18002 Interruptor
Reductor SR12013 LF de velocidad
Sick M40Z025023TB1 fotoeléct. Barrera
PR Acoplamiento SA00177
cable 4p Conector micro 4m 889DF4AC5
Brazo actuador 399 largo:
Rodillo 114mm palanca morro largo:
Rodillo 330180000 libre
shaft bar 351819028 Nose
lineal excel Nook Rodamiento
Fotocélula Banner
cable EL03926 Prox. Sensor
EL99942 Ventilador
Cilindro reparado HY00115 hidráulico
SR10510 Reductor velocidad de
barra largo Rodillo de 98mm morro
Rueda horno nivel de centrado
SENSOR:VIBRATION,IP68,500G RANGE,MAX165°
| XSM-3034-30-PP iglidur X sleeve bearing
KIT:HI-TECH,OK143521,O-RING 5/2 WAY,VLV a |
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)