import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S).(?!\\S)";
final String string = "a interior Casquillo Dint.50 100\n"
+ "brg aligning Self MM161Z end rod\n"
+ "del eje4 Junta hendidura\n"
+ "352 Junta tórica .20279\n"
+ "2z/C3GJN Rodamiento\n"
+ "pos. Ser. 440PM18002 Interruptor\n"
+ "Reductor SR12013 LF de velocidad\n"
+ "Sick M40Z025023TB1 fotoeléct. Barrera\n"
+ "PR Acoplamiento SA00177\n"
+ "cable 4p Conector micro 4m 889DF4AC5\n"
+ "Brazo actuador 399 largo:\n"
+ "Rodillo 114mm palanca morro largo:\n"
+ "Rodillo 330180000 libre\n"
+ "shaft bar 351819028 Nose\n"
+ "lineal excel Nook Rodamiento\n"
+ "Fotocélula Banner\n"
+ "cable EL03926 Prox. Sensor\n"
+ "EL99942 Ventilador\n"
+ "Cilindro reparado HY00115 hidráulico\n"
+ "SR10510 Reductor velocidad de\n"
+ "barra largo Rodillo de 98mm morro\n"
+ "Rueda horno nivel de centrado\n"
+ "SENSOR:VIBRATION,IP68,500G RANGE,MAX165°\n"
+ " | XSM-3034-30-PP iglidur X sleeve bearing\n"
+ "KIT:HI-TECH,OK143521,O-RING 5/2 WAY,VLV a |\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}