re = /(https?\:\/\/)?(www\.)?([a-z0-9]+\.)+([a-z]{2,})(\/[a-zA-Z0-9\-_]+)+(\.)+(jpg|png|bmp|jpeg){1}/
str = 'https://i.imgur.com/PYiHYPX.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end