package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?\:\/\/)?(www\.)?([a-z0-9]+\.)+([a-z]{2,})(\/[a-zA-Z0-9\-_]+)+(\.)+(jpg|png|bmp|jpeg){1}`)
var str = `https://i.imgur.com/PYiHYPX.jpg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}