import Foundation
let pattern = #"<div\sid=\"olpProductDetails[\s\S]*?<h1[\s\S]*?<div[\s\S]*?<span[\s\S]*?>[\s\S]*?\s*<\/span>\s*<\/div>\s*[\s\S]*?[\s]+<\/h1>[\s\S]*?<div\sid=\"olpProductByline\"[\s\S]*?>[\s\S]*?by\s([\s\S]*?)[\s]+<\/div>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div id="olpProductDetails" class="a-fixed-left-grid-col a-col-right" style="padding-left:0%;float:left;">
<h1 class="a-size-large a-spacing-none" role="main"> <div class="a-section a-spacing-none olpSubHeadingSection"> <span class="a-size-base a-color-secondary"> </span> </div> Keds Women's Chillax Washed Laceless Slip-On Sneaker, Taupe, 8 M US
</h1>
<div id="olpProductByline" class="a-section a-spacing-mini">
by Keds
</div>
<div class="a-section a-spacing-small">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)