$re = '/<div\sid=\"olpProductDetails[\s\S]*?<h1[\s\S]*?<div[\s\S]*?<span[\s\S]*?>[\s\S]*?\s*<\/span>\s*<\/div>\s*[\s\S]*?[\s]+<\/h1>[\s\S]*?<div\sid=\"olpProductByline\"[\s\S]*?>[\s\S]*?by\s([\s\S]*?)[\s]+<\/div>/m';
$str = '<div id="olpProductDetails" class="a-fixed-left-grid-col a-col-right" style="padding-left:0%;float:left;">
<h1 class="a-size-large a-spacing-none" role="main"> <div class="a-section a-spacing-none olpSubHeadingSection"> <span class="a-size-base a-color-secondary"> </span> </div> Keds Women\'s Chillax Washed Laceless Slip-On Sneaker, Taupe, 8 M US
</h1>
<div id="olpProductByline" class="a-section a-spacing-mini">
by Keds
</div>
<div class="a-section a-spacing-small">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);