import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*\\(.*\\)";
final String string = "Фицджеральд, Фрэнсис Скотт\n"
+ "Экман П.\n"
+ "Мазаник, Таисия Михайловна, Далидович, Анастасия , Цивилько, Надежда Михайловна\n"
+ "Беляева Т.И., отв. ред.\n"
+ "Сафарли, Эльчин\n"
+ "Колесникова, Елена Владимировна\n"
+ "Несбё, Ю\n"
+ "Плешаков, Андрей Анатольевич\n"
+ "Брубейкер Э.\n"
+ "Брэдбери Р.\n"
+ "Маланка Татьяна Григорьевна, Прищеп Анна Александровна, Пылаева Инна Александровна\n"
+ "Н. М. Павлова\n"
+ "Пашкова Л.\n"
+ "Егорова А. А.\n"
+ "Созонова, Надежда Николаевна, Куцина, Екатерина Владимировна\n"
+ "Е. М. Зорина, М. В. Зорин\n"
+ "Т. Г. Николенко, И. И. Кошманова\n"
+ "Токаева Т. Э., Кустова Л.Б.\n"
+ "Лутцева Е. А.\n"
+ "Дорофеев Г., Седова Е., Шестаков С., Пчелинцев С.\n"
+ "Квактун Г.Г., Квактун И.Г.\n"
+ "Сизова Е.В.\n"
+ "С. Н. Лозовая\n"
+ "Кучук Оксана Владимировна\n"
+ "др., Тонких А.П., Козлова С.А., Демидова Т.Е.\n"
+ "др., Гладышева Н. Н., Губарькова Е.В., Шилова В.Н., Гнусарева И. А.\n"
+ "О. В. Мешкова\n"
+ "Голуб Ирина Борисовна\n"
+ "др., Моргунова А. Б.\n"
+ "Н. В. Дубровская\n"
+ "Субботина, Елена Александровна\n"
+ "Карпухина Наталия Александровна\n"
+ "Агеева И.Д.\n"
+ "Л. Г. Петерсон, Э. Р. Барзунова, А. А. Невретдинова\n"
+ "Наталья Суркова,Ольга Яровая\n"
+ "Аким Я.Л., Коринец Ю.И., Пришвин М.М.\n"
+ "Ханнанов Н., Никифоров Г., Орлов В.\n"
+ "др., Бибекова О. А.\n"
+ "Т. Н. Видеман\n"
+ "Ященко Иван Валерьевич, Шноль Дмитрий Эммануилович, Высоцкий Иван Ростиславович, Столбов Константин Михайлович\n"
+ "Смирнова И. Г.\n"
+ "Сергей Савушкин\n"
+ "Комиссарова В.\n"
+ "Коновалова Н., Иванов Ю., Гилев М. (авт.-сост.), Иванов М.\n"
+ "Курукин, Игорь Владимирович, и другие, , Шестаков, Владимир Алексеевич\n"
+ "Казакова Р.Г.\n"
+ "Бортникова Е.\n"
+ "Канчурина Р., БерсеневаТ., Гылка Е. и др.\n"
+ "Лысенко Ф., Кулабухов С. (ред.)\n"
+ "Большаков В.\n"
+ "Рид Т.М.\n"
+ "Воскресенская Е.О., Ткаченко Е.М., Слаутина Н.В.\n"
+ "Н. А. Червякова\n"
+ "Сертакова Н. М.\n"
+ "Пашкова Людмила Ивановна\n"
+ "Егорова Антонина Алексеевна\n"
+ "Зорина Е.М., Зорин М.В.\n"
+ "Жукова, Олеся Станиславовна\n"
+ "Миловидов В.\n"
+ "Токаева Т.Э.\n"
+ "Лутцева Е.А.\n"
+ "Дорофеев Георгий Владимирович, Шестаков Сергей Алексеевич, Седова Елена Александровна, Пчелинцев Сергей Валентинович\n"
+ "Квактун Галина Гиршевна, Квактун Ирина Гиршевна\n"
+ "Картушина М.Ю.\n"
+ "Лободина Н. (сост.)\n"
+ "Сизова Е., Харитонова Н.\n"
+ "Гетцель В. (ред.)\n"
+ "О. В. Кучук\n"
+ "Козлова Светлана Александровна, Демидова Тамара Евгеньевна, Тонких Александр Павлович\n"
+ "Гладышева Наталья Николаевна, Губарькова Елена Владимировна, Шилова Вера Николаевна\n"
+ "Руднева А.В.\n"
+ "А. Б. Моргунова, Н. В. Яковлева\n"
+ "Наталия Нищева\n"
+ "О. В. Павлова\n"
+ "Новоторцева Н.В.\n"
+ "Севостьянова Елена Олеговна\n"
+ "Лаврова Н.М.\n"
+ "Агеева И.\n"
+ "Пустовалова О. П., Фролова Н. Г.\n"
+ "Зеркальная Т.В., сост.\n"
+ "Ханнанов Наиль Кутдусович, Орлов Владимир Алексеевич, Никифоров Геннадий Гершкович\n"
+ "Бибекова О.А.\n"
+ "Бостельман А., Финк М.\n"
+ "И. Г. Смирнова\n"
+ "Теплюк С.Н., Савушкин С.Н.\n"
+ "Л. Ю. Комиссарова\n"
+ "Н. Г. Коновалова, Ю. П. Иванов, М. Л. Гилев";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}