#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*\(.*\)"
Local $sString = "Фицджеральд, Фрэнсис Скотт" & @CRLF & _
"Экман П." & @CRLF & _
"Мазаник, Таисия Михайловна, Далидович, Анастасия , Цивилько, Надежда Михайловна" & @CRLF & _
"Беляева Т.И., отв. ред." & @CRLF & _
"Сафарли, Эльчин" & @CRLF & _
"Колесникова, Елена Владимировна" & @CRLF & _
"Несбё, Ю" & @CRLF & _
"Плешаков, Андрей Анатольевич" & @CRLF & _
"Брубейкер Э." & @CRLF & _
"Брэдбери Р." & @CRLF & _
"Маланка Татьяна Григорьевна, Прищеп Анна Александровна, Пылаева Инна Александровна" & @CRLF & _
"Н. М. Павлова" & @CRLF & _
"Пашкова Л." & @CRLF & _
"Егорова А. А." & @CRLF & _
"Созонова, Надежда Николаевна, Куцина, Екатерина Владимировна" & @CRLF & _
"Е. М. Зорина, М. В. Зорин" & @CRLF & _
"Т. Г. Николенко, И. И. Кошманова" & @CRLF & _
"Токаева Т. Э., Кустова Л.Б." & @CRLF & _
"Лутцева Е. А." & @CRLF & _
"Дорофеев Г., Седова Е., Шестаков С., Пчелинцев С." & @CRLF & _
"Квактун Г.Г., Квактун И.Г." & @CRLF & _
"Сизова Е.В." & @CRLF & _
"С. Н. Лозовая" & @CRLF & _
"Кучук Оксана Владимировна" & @CRLF & _
"др., Тонких А.П., Козлова С.А., Демидова Т.Е." & @CRLF & _
"др., Гладышева Н. Н., Губарькова Е.В., Шилова В.Н., Гнусарева И. А." & @CRLF & _
"О. В. Мешкова" & @CRLF & _
"Голуб Ирина Борисовна" & @CRLF & _
"др., Моргунова А. Б." & @CRLF & _
"Н. В. Дубровская" & @CRLF & _
"Субботина, Елена Александровна" & @CRLF & _
"Карпухина Наталия Александровна" & @CRLF & _
"Агеева И.Д." & @CRLF & _
"Л. Г. Петерсон, Э. Р. Барзунова, А. А. Невретдинова" & @CRLF & _
"Наталья Суркова,Ольга Яровая" & @CRLF & _
"Аким Я.Л., Коринец Ю.И., Пришвин М.М." & @CRLF & _
"Ханнанов Н., Никифоров Г., Орлов В." & @CRLF & _
"др., Бибекова О. А." & @CRLF & _
"Т. Н. Видеман" & @CRLF & _
"Ященко Иван Валерьевич, Шноль Дмитрий Эммануилович, Высоцкий Иван Ростиславович, Столбов Константин Михайлович" & @CRLF & _
"Смирнова И. Г." & @CRLF & _
"Сергей Савушкин" & @CRLF & _
"Комиссарова В." & @CRLF & _
"Коновалова Н., Иванов Ю., Гилев М. (авт.-сост.), Иванов М." & @CRLF & _
"Курукин, Игорь Владимирович, и другие, , Шестаков, Владимир Алексеевич" & @CRLF & _
"Казакова Р.Г." & @CRLF & _
"Бортникова Е." & @CRLF & _
"Канчурина Р., БерсеневаТ., Гылка Е. и др." & @CRLF & _
"Лысенко Ф., Кулабухов С. (ред.)" & @CRLF & _
"Большаков В." & @CRLF & _
"Рид Т.М." & @CRLF & _
"Воскресенская Е.О., Ткаченко Е.М., Слаутина Н.В." & @CRLF & _
"Н. А. Червякова" & @CRLF & _
"Сертакова Н. М." & @CRLF & _
"Пашкова Людмила Ивановна" & @CRLF & _
"Егорова Антонина Алексеевна" & @CRLF & _
"Зорина Е.М., Зорин М.В." & @CRLF & _
"Жукова, Олеся Станиславовна" & @CRLF & _
"Миловидов В." & @CRLF & _
"Токаева Т.Э." & @CRLF & _
"Лутцева Е.А." & @CRLF & _
"Дорофеев Георгий Владимирович, Шестаков Сергей Алексеевич, Седова Елена Александровна, Пчелинцев Сергей Валентинович" & @CRLF & _
"Квактун Галина Гиршевна, Квактун Ирина Гиршевна" & @CRLF & _
"Картушина М.Ю." & @CRLF & _
"Лободина Н. (сост.)" & @CRLF & _
"Сизова Е., Харитонова Н." & @CRLF & _
"Гетцель В. (ред.)" & @CRLF & _
"О. В. Кучук" & @CRLF & _
"Козлова Светлана Александровна, Демидова Тамара Евгеньевна, Тонких Александр Павлович" & @CRLF & _
"Гладышева Наталья Николаевна, Губарькова Елена Владимировна, Шилова Вера Николаевна" & @CRLF & _
"Руднева А.В." & @CRLF & _
"А. Б. Моргунова, Н. В. Яковлева" & @CRLF & _
"Наталия Нищева" & @CRLF & _
"О. В. Павлова" & @CRLF & _
"Новоторцева Н.В." & @CRLF & _
"Севостьянова Елена Олеговна" & @CRLF & _
"Лаврова Н.М." & @CRLF & _
"Агеева И." & @CRLF & _
"Пустовалова О. П., Фролова Н. Г." & @CRLF & _
"Зеркальная Т.В., сост." & @CRLF & _
"Ханнанов Наиль Кутдусович, Орлов Владимир Алексеевич, Никифоров Геннадий Гершкович" & @CRLF & _
"Бибекова О.А." & @CRLF & _
"Бостельман А., Финк М." & @CRLF & _
"И. Г. Смирнова" & @CRLF & _
"Теплюк С.Н., Савушкин С.Н." & @CRLF & _
"Л. Ю. Комиссарова" & @CRLF & _
"Н. Г. Коновалова, Ю. П. Иванов, М. Л. Гилев"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")