$re = '/^(?:(?!\bbag\b).)*\bred\b.+?\bbag\b/m';
$str = 'choose balls if they are in red bag, or they are in green bag
choose balls if they are in green bag, or they are in red bag
choose balls if they are in red bag
choose balls if they are in green bag
bag red bag
red bag red
green bag red bag
red bags';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);