const regex = /^(?:(?!\bbag\b).)*\bred\b.+?\bbag\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!\\bbag\\b).)*\\bred\\b.+?\\bbag\\b', 'gm')
const str = `choose balls if they are in red bag, or they are in green bag
choose balls if they are in green bag, or they are in red bag
choose balls if they are in red bag
choose balls if they are in green bag
bag red bag
red bag red
green bag red bag
red bags`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}